OpsMgr R2 Prerequisites

One of the nice things about Operations Manager even from the early versions is the ability to run the prerequisite checker so you know what is required before you start the install. I recommend using this before starting to do any installs. It saves time later.

From the Quick Start Guide

When all components are selected, the Prerequisite Viewer checks for the presence of Windows Server 2003 SP1, SQL Server 2005 SP1 or higher, SQL Server Reporting Services SP1, MDAC version 2.80.1022.0 or higher, .NET Framework version 2.0, .NET Framework 3.0 components, WS-MAN v1.1, and Windows Power Shell. It then checks to ensure that the WWW service is running and set to automatic startup mode.

The checker does not mention the SQL version required but as the notes above say, it needs to be at least SQL 2005 SP1 which is the same as OpsMgr 2007 SP1.

This checker can check for all components or you can just check the components that will be installed on the server that you are checking.

All components

clip_image002

Database

clip_image002[4]

Server

clip_image004

New requirement for Cross Platform Extentions – WS-management 1.1. This is only a warning (so it will not stop the install) as it is only required if you are pushing out agents to UNIX or Linux servers.

clip_image006

Console

clip_image008

Console with PowerShell

clip_image010

Web Console

clip_image012

This is a new requirement for the web console – ASP.NET AJAX 1.0. As this is a failure the install will not be allowed.

Note that after it is installed the requirement is no longer shown.

clip_image014

Reporting

clip_image016

Data Warehouse

clip_image018

To get the missing bits

· WS-MAN v1.1, available at: http://go.microsoft.com/fwlink/?LinkID=133219

· .NET Framework 2.0, available at: http://go.microsoft.com/fwlink/?LinkID=64221

· .NET Framework 3.0 components, available at: http://go.microsoft.com/fwlink/?LinkID=71270

· Windows PowerShell, available at: http://go.microsoft.com/fwlink/?LinkID=71311

Links to Optional Prerequisites

The Operations Manager 2007 R2 Prerequisite checker does not confirm the presence of the following items and you must install them manually if you want that functionality

· For creating and editing product or company knowledge in management packs you must install Microsoft Office Word 2003 (or 2007) with the .NET Programmability feature and Microsoft Visual Studio 2005 Tools for the Microsoft Office System, available at: http://go.microsoft.com/fwlink/?LinkID=53267

· If you will install agents manually, you must install MSXML 6.0, available at http://go.microsoft.com/fwlink/?LinkID=76343. MSXML 6.0 requires Windows Installer 3.1, available at: http://go.microsoft.com/fwlink/?LinkID=77051. MSXML 6.0 is automatically installed with the agent when the agents are pushed out.

MP Authoring Console

Although this does not have a prerequisite checker it still does a check and if it fails you can check the log.

clip_image002[6]

Note that the .Net requirements are higher than for the other components.

 

Hope this helps in your planning and installations.

Ian

www.cosiris.co.uk

Advertisements

Comments are closed.

%d bloggers like this: